Joomla Updates

Joomla! Updates ab 190,00 €Der Support des Content-Management-Systems (CMS) Joomla! Version 2.5 lief bereits zum 31.12.2014 aus. Die Vorgänger-Versionen 1.5 und 1.7, von denen ebenfalls noch zahlreiche Webpräsenzen existieren, werden noch länger nicht mehr aktualisiert.

Sollten Sie Ihre Website erneuern?

Ein klares Ja! Updates werden nicht zuletzt auch aus Sicherheitsgründen dringend empfohlen. Nicht zuletzt aufgrund fehlenden Sicherheitsaktualisierungen und fehlender Updates ist Ihr Internetauftritt ein leichtes Ziel für Angriffe von außen. Der positive Nebeneffekt einer Aktualisierung auf Joomla! 3 ist die Option auf eine auch mit mobilen Endgeräten optimalen Darstellung. Zudem erwarten den Benutzer viele Neuerungen und Vereinfachungen in der Benutzerführung und nicht zuletzt mit der 2-Faktor-Authentifizierung höhere Sicherheitsstandards.

Was kostet mich ein Update bzw. ein Upgrade?

Ein Update ist bereits ab 190,00 € möglich!

Die unterschiedlichen Versionssprünge bei Joomla, erfordern jedoch ggf. Zwischenupdates und Mehrfachsicherungen. Ihr altes Template muss u.U. angepasst oder ersetzt werden. Verwendete Erweiterungen von Drittanbietern sind eventuell nicht updatefähig und müssen ausgetauscht werden. Bitte fordern Sie ein individuelles Angebot an!

Checkliste - welche Voraussetzungen benötigen Sie für joomla! 3?

empfohlene Anforderungen für Joomla 3.x (joomla.org, Stand 30.05.2017)

Server: Apache 2.4 + (mit mod_mysql, mod_xml und mod_zlib)
Software: PHP 5.6 + oder 7
Datenbank: MySQL 5.5.3 +

Vorausschau

Mit welcher Joomla! Version betreiben Sie Ihre Website?

Erfüllen Ihre Website und Ihr Webserver/ Hoster alle Anforderungen für das Joomla! Upgrade z.B. von Version 2.5 auf 3?

Funktioniert Ihr verwendetes Template auch unter Joomla! 3?
Haben Sie vorsorglich eine Sicherung der Website (Daten und Datenbank) erstellt?
Setze Sie Erweiterungen von Drittanbietern ein und sind diese auch für Joomla! 3 verfügbar?
Sind Sie in der Lage das Update/ Ugrade allein durchzuführen?

 

Referenzen (joomla.org, Stand 30.05.2017)

PHP 5.3.1 ist erforderlich für die Versionen 3.0 bis 3.2.

Ab Version 3.3 ist mindestens PHP 5.3.10 nötig.

Nur Joomla! Versionen 3.5 und höher sind mit PHP 7 kompatibel.

Joomla! ist noch nicht kompatibel mit MySQL 6.x.
Um Suchmaschinenfreundliche URLs einzusetzen, muss die Apache mod_rewrite-Erweiterung installiert sein.
Die mod_suphp Erweiterung oder mod_fcgid - Erweiterung wird empfohlen damit Joomla Dateien hochladen und mit sicheren Datei-Berechtigungen ausführen kann.

 

detaillierte Infos und technical requirements:

https://docs.joomla.org/Technical_requirements/de